Archivio

Archive for maggio 2014

Java: Impossibile convalidare il certificato. L’applicazione non verrà eseguita.

Schermata da 2014-05-27 12:34:11
Lanciando un applicazione web molto vecchia si può incorrere in questo errore:
Impossibile convalidare il certificato. L'applicazione non verrà eseguita.
per poter risolvere bisogna disabilitare una voce dentro il file java.security.
Il file su Fedora 20 si trova in /usr/java/jre1.7.0_55/lib/security/java.security.
La voce da commentare è la seguente:
jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024

Annunci
Categorie:bash, java

Windows 2003: loop di windows update

Appena installato un server windows 2003, dopo aver fatto l’aggiornamento con windows update al reboot ottengo un loop al lancia di un nuovo windows update.
Nei log di windowsupdate.log trovo questo errore:

FATAL: Update required for C:\WINDOWS\system32\wuweb.dll: target version = 5.7.3790.3959, required version = 7.0.6000.381

Quindi non ho fatto altro che disabilitare “aggiornamenti automatici”, riavviare la macchina e sostiuire wuweb.dll con lo stesso file ma versione differente preso da un altro windows 2003.
A questo punto ho riavviato windows.